git-pbuilder 1.37

A couple more simple fixes in the continuing failure of this script to get rewritten in Python and integrated properly with the git-buildpackage distribution.... (But hey, I'm caught up on writing book reviews!)

When used with qemubuilder, it was checking for the existence of entirely the wrong file. Thanks to James Clarke for the patch.

Running git-pbuilder with a command requires sudo and an appropriate sudo configuration. There's not much we can do to detect the latter, but Guido G√ľnther suggested at least detecting the former. git-pbuilder now does so and prints out a hopefully informative error. This is also better-documented in the man page.

You can get the latest release from my scripts page.

Posted: 2015-10-24 18:00 — Why no comments?

Last modified and spun 2015-10-31